GoW Problems - Screenshots, Discussion of Possible Issues

Forum for asking questions and discussing technical problems related to your OESM hosted server.

Moderators: FeLiX, Mr.Magoo

GoW Problems - Screenshots, Discussion of Possible Issues

Postby Azlan » Thu Apr 04, 2002 9:19 am

Thanks for taking the time to research the issue guys. Why don't we try taking off CSGuard for a time to see how it effects the server?
Azlan
noobeh
noobeh
 
Posts: 7
Joined: Thu Jan 31, 2002 2:01 am
Location: TN

GoW Problems - Screenshots, Discussion of Possible Issues

Postby DLinkOZ » Thu Apr 04, 2002 11:45 am

That's actually what I'd like to try next after I see if the config memory allocation does anything. As it stands, you guys have csguard, adminmod, and metamod (duh). Not even sure why you've got adminmod on there, I'd assume you're all adept at using rcon and wouldn't need additional useless software.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

GoW Problems - Screenshots, Discussion of Possible Issues

Postby Axiom » Thu Apr 04, 2002 1:04 pm

http://www.oesm.org/images/screenshots/

Above are screenshots that myself(eastcoast) and DLinkOZ(near the dallas colo) both took at what we understand to be peak times.

Also, contained within that directory are screenshots of the other two servers that are hosted on that box. Notice, neither of them has any issues where ping, loss or choke are concerned.

One thing dlinkoz and myself have noticed is that the servers running CSGuard have one quirky thing. The scoreboard pings and the net_graph pings are significantly different. We have an idea of what may be causing this.

As for loss and people on the east coast complaining, I have tested it from 3 different locations where I have cable access from. Each one results in no loss, no choke and no ping issues. Obviously, I can't test from the west coast.

Are we denying that issues exist? No. There may be some unseen issues, but as it stands now, none of them have anything to do with OESM's hardware, software or configuration.
Axiom
Site Admin
Site Admin
 
Posts: 292
Joined: Fri Oct 26, 2001 1:01 am

GoW Problems - Screenshots, Discussion of Possible Issues

Postby DLinkOZ » Thu Apr 04, 2002 1:11 pm

Part of my discussion with nasty tonight:

"2 servers on the same machine. Neither give me any problems (rules out the box). One runs CSG, one doesn't. The one that doesn't shows correct scoreboard info when full. The one that does gets inaccurate scoreboard info after 16 players. So it's either CSG, or configuration."

"Oh yeah. A 3rd server on that box. Also runs CSG, also gets inaccurate scoreboard info at >16 players. Still gives me no network problems."

I've dedicated 8mb of ram just for GoW's server to load config files in memory since CSG's configs are so huge. While this isn't a fix for any network problems people may experience (which I don't experience, which makes the troubleshooting process that much harder), I want to see if it remedies the scoreboard inaccuracy as it only happens with the servers who have 18 player limits, and only when they get to 17 or 18.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

GoW Problems - Screenshots, Discussion of Possible Issues

Postby Azlan » Thu Apr 04, 2002 6:12 pm

I'm open to trying anything to get the server as smooth as possible, just let me know if i can be of assistance.
Azlan
noobeh
noobeh
 
Posts: 7
Joined: Thu Jan 31, 2002 2:01 am
Location: TN

GoW Problems - Screenshots, Discussion of Possible Issues

Postby DLinkOZ » Thu Apr 04, 2002 11:39 pm

I removed metamod from the server to test. I've played in there the past 2 nights now, never once has my ping gone over 50ms, averages around 35-40ms. Next time the server restarts, metamod will be off, and we'll see if that has any effect on the scoreboard. If it does, we'll add one thing at a time (metamod, csg, adminmod) and go from there.

Btw Azlan, here's your trace from the server (11:45pm EST):

traceroute to 68.47.160.8 (68.47.160.8), 30 hops max, 38 byte packets
1 core2.dllstx.theplanet.com (216.185.105.1) 0.821 ms 0.738 ms 5.858 ms
2 f13.ba01.b000326-0.dfw01.demarc.cogentco.com (66.28.8.5) 1.205 ms 6.941 ms 1.110 ms
3 g1-2.core01.dfw01.atlas.cogentco.com (66.28.5.153) 54.464 ms 56.214 ms 54.582 ms
4 p15-0.core02.dfw01.atlas.cogentco.com (66.28.4.26) 55.420 ms 55.344 ms 55.390 ms
5 64.124.51.169.cogentco.com (64.124.51.169) 38.694 ms 37.463 ms 36.108 ms
6 core2-dfw3-oc48.dfw2.above.net (208.184.232.113) 41.046 ms 41.062 ms 41.021 ms
7 dca2-dfw2-oc48-2.dca2.above.net (208.184.232.133) 41.567 ms 40.738 ms 41.036 ms
8 iad1-dca2-oc192.iad1.above.net (208.184.233.130) 42.105 ms 41.383 ms 41.053 ms
9 core1-core5-oc48.iad1.above.net (208.185.0.145) 40.807 ms 40.620 ms 41.390 ms
10 att-above-oc12.att.net.12.125.64.in-addr.arpa (64.125.12.6) 31.129 ms 31.141 ms 32.288 ms
11 gbr4-p50.wswdc.ip.att.net (12.123.9.54) 31.167 ms 30.828 ms 30.999 ms
12 gbr4-p30.attga.ip.att.net (12.122.2.225) 29.583 ms 29.918 ms 29.136 ms
13 gbr2-p100.attga.ip.att.net (12.122.1.198) 30.398 ms 34.443 ms 29.475 ms
14 gar1-p370.attga.ip.att.net (12.123.21.5) 29.502 ms 29.202 ms 30.229 ms
15 12.124.59.102 (12.124.59.102) 34.362 ms 33.718 ms 33.909 ms
16 68.47.160.53 (68.47.160.53) 35.132 ms 34.001 ms 34.147 ms
17 cas02.shrpsr01.tn.comcast.net (68.47.160.8) 33.827 ms 44.741 ms 34.037 ms

Looks very good.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

GoW Problems - Screenshots, Discussion of Possible Issues

Postby DLinkOZ » Fri Apr 05, 2002 2:09 am

Yes, it's the route packets take from the server to your happy little pc.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

GoW Problems - Screenshots, Discussion of Possible Issues

Postby Azlan » Fri Apr 05, 2002 12:22 pm

In general, I usually have good ping there. However, when I used to pub all the time, there were a lot of people with irregular ping issues. You can say it's on their end, but if you go play at our ReconGamer server, you'll notice that ping is steady and the same for pretty much everyone that plays there most of the time.

This is my main concern, it is irregular for more than a handful of people to have a connection issue on their side at any given time inside of a GOOD server. Which I was told OESM1 was.

That said, did taking off MetaMod do anything?
Azlan
noobeh
noobeh
 
Posts: 7
Joined: Thu Jan 31, 2002 2:01 am
Location: TN

GoW Problems - Screenshots, Discussion of Possible Issues

Postby Azlan » Fri Apr 05, 2002 1:14 pm

"MY" trace?
Azlan
noobeh
noobeh
 
Posts: 7
Joined: Thu Jan 31, 2002 2:01 am
Location: TN

GoW Problems - Screenshots, Discussion of Possible Issues

Postby DLinkOZ » Sat Apr 06, 2002 1:27 am

While I can't speak to the issue of how the game "feels" to people, the scoreboard issue is definitely resolved with the removal of metamod/adminmod/csguard. Here's a ss I took 2 minutes ago in your server:

http://www.oesm.org/images/torch20000.JPG

Clearly pings in the scoreboard match netgraph. The highest ping in the joint is 132, with 11 out of 17 being under 100ms (5 of those being in the 50's or lower, 9 being 70's or lower, etc). In checking with halfd right now (this very instant) average ping is 86 with a full 18 players. Scoreboard (halfd shows scoreboard pings, not what netgraph would be showing, so it's a good indicator of that particular issue) shows pings ranging from as low as 33 up to as high as 133, with only 5 over 100ms. Please try this tonight and see how it goes. Tomorrow I'll add metamod back in, then adminmod, then csg. We'll keep an eye on it and see what the scoreboard cause is.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

GoW Problems - Screenshots, Discussion of Possible Issues

Postby Azlan » Sat Apr 06, 2002 1:37 pm

roger
Azlan
noobeh
noobeh
 
Posts: 7
Joined: Thu Jan 31, 2002 2:01 am
Location: TN

GoW Problems - Screenshots, Discussion of Possible Issues

Postby DLinkOZ » Mon Apr 08, 2002 3:52 pm

I've got metamod and adminmod back on, and the scoreboards appear to still be working properly. So that problems seems to be with CSGuard. How have pings and such been in there over the weekend? I could say how they are for me, but we all know that one.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

GoW Problems - Screenshots, Discussion of Possible Issues

Postby Azlan » Tue Apr 09, 2002 5:05 pm

I've had some people come to me and say ping's are better. Let's keep CSGuard off for awhile and see if things continue to improve.

Thanks again for your assistance.
Azlan
noobeh
noobeh
 
Posts: 7
Joined: Thu Jan 31, 2002 2:01 am
Location: TN

GoW Problems - Screenshots, Discussion of Possible Issues

Postby Axiom » Tue Apr 09, 2002 7:14 pm

See, I do care.
Axiom
Site Admin
Site Admin
 
Posts: 292
Joined: Fri Oct 26, 2001 1:01 am


Return to Technical Support / Technical Q and A

Who is online

Users browsing this forum: No registered users and 4 guests

cron