Server Problem

Forum provided for public use.

Moderators: FeLiX, Mr.Magoo

Server Problem

Postby WarPig » Mon Jul 16, 2001 8:59 pm

hey, everytime i upload a map to my server and try to change to it, it crashes the server, whats up with that, do i have to wait sum time b4 it will work? or is there sumtin wrong. our server is the KVO one, and we need maps for league play. please help me with this issue
WarPig
noobeh
noobeh
 
Posts: 6
Joined: Tue Jun 26, 2001 1:01 am

Server Problem

Postby Mr.Magoo » Mon Jul 16, 2001 9:07 pm

what maps?
Mr.Magoo
Moderator
Moderator
 
Posts: 297
Joined: Thu Nov 16, 2000 2:01 am

Server Problem

Postby DLinkOZ » Mon Jul 16, 2001 9:19 pm

Please tell me a time and what map it is. Usually, the biggest problem is either missing wad files (or other required secondary files), or case sensitivity problems. Seems too many map makers forget there are a good deal of linux servers, and don't take into account that linux is a natively case sensitive OS. For example, 2morefort WILL crash on you without a simple 2 second fix. It's because the map maker made a call to a wad named HalfLife.wad, when Valve names it halflife.wad. Simple, small difference, disasterous results.

So let me know what time it occurred so I can check the crash logs and see what the error was.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

Server Problem

Postby DLinkOZ » Mon Jul 16, 2001 9:21 pm

I just looked at the directory that houses the crash logs. All crashes occurred within a 45 minute period. Here's your culprit:

L 07/16/2001 - 20:59:13: Server cvar "mp_chattime" = "10"
L 07/16/2001 - 20:59:13: Server cvars end
Error WARNING: couldn't open valve/openfire.wad

When uploading maps, it is VITAL to upload wad files. Just upload openfire.wad to the valve directory, and everything will be right as rain.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

Server Problem

Postby WarPig » Mon Jul 16, 2001 9:51 pm

i also uploaded darkness and it crashed each time, i know i put in everyfile cuz i d/ed it from the STA site, and it still crashed
WarPig
noobeh
noobeh
 
Posts: 6
Joined: Tue Jun 26, 2001 1:01 am

Server Problem

Postby [OESM]Sephiroth » Mon Jul 16, 2001 10:16 pm

All hail the Unreal engine! All sounds, textures, etc are incorprated right into the maps, no need for five-thousand wads! Oh wait, I'm sorry, that's every other game engine [img]images/smiles/icon_biggrin.gif[/img]... Seriously though, Half-Life rocks, just wish map designers would stop trying to go that damned far in-depth with their maps unless they include the crap in the map zip.

-The Great Sephiroth
[OESM]Sephiroth
I'd rather be posting!
I'd rather be posting!
 
Posts: 411
Joined: Sun Apr 29, 2001 1:01 am
Location: Raleigh, NC

Server Problem

Postby DLinkOZ » Mon Jul 16, 2001 10:46 pm

Ok, you've now experienced the two things I mentioned. The first, missing wad files. This time, with Darkness, was the case sensitivity. Here's your crash reason:

Error WARNING: couldn't open valve/ma1.wad

Notice it's all lower case. The file on the server is upper case. Just change that and you'll be set.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

Server Problem

Postby WarPig » Tue Jul 17, 2001 11:39 am

Ok that one file was supposed to go into half-life/tfc as to what the zip had, but now im having a problem, i cant get into our FTP now... i know its probably me doing sumtin wrong but i still need the help. Thanx
WarPig
noobeh
noobeh
 
Posts: 6
Joined: Tue Jun 26, 2001 1:01 am

Server Problem

Postby Mr.Magoo » Tue Jul 17, 2001 1:04 pm

Click Me
Then search for ws ftp. IE doesnt do ftp well.
Mr.Magoo
Moderator
Moderator
 
Posts: 297
Joined: Thu Nov 16, 2000 2:01 am

Server Problem

Postby DLinkOZ » Tue Jul 17, 2001 2:38 pm

Yeah, IE is absolutely horrid for ftp use. In fact, I've seen it do completely stupid things while true ftp clients had no problems (aka, not letting me in and such). I would strongly urge you to use a good ftp client, such as cute, ws, or (my personal fave) securefx.
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

Server Problem

Postby DLinkOZ » Wed Jul 18, 2001 12:25 am

Yeah, I believe if it's missing, it'll default to looking in the valve directory. But it's the case sensitivity that killed the server.

As for the ftp, I just tried with my account and got in with no problems. Do you connect and it just won't log in? Or can you not connect at all?
DLinkOZ
Site Admin
Site Admin
 
Posts: 1643
Joined: Sun Nov 12, 2000 2:01 am
Location: McKinney, TX

Server Problem

Postby WarPig » Wed Jul 18, 2001 12:39 am

It will not connect at all, i get an error saying... b4 i log in (i connect through IE and it worked fine yesterday) "An error occurred reading the contents of the folder. make sure the file name is valid and you have permission to access the location specified ---- Details: The server name of address could not be resolved."
This makes me think im using the wrong ftp name, but i was using the exact one yesterday and it stayed in my IE recently visited sites list, so it cant be wrong....
WarPig
noobeh
noobeh
 
Posts: 6
Joined: Tue Jun 26, 2001 1:01 am


Return to FO.Net's Public Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron